Dayforce Application System Slowness
Incident Report for PADNOS
Resolved
This incident has been resolved.
Posted Nov 05, 2024 - 11:19 EST
Investigating
Dayforce is currently investigating system slowness.

Users may experience the following:

-Intermittent inability to access the system
-Slow loading times
-Slow system navigation
-All hardware clocks will continue to accept punches as normal
Posted Nov 04, 2024 - 10:17 EST
This incident affected: Ceridian Dayforce HCM.