Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 26, 2026 - 02:00 EDT
Scheduled
PRODUCTION MAINTENANCE INFORMATION Activity: Scheduled Maintenance Reason: Application Upgrade to Dayforce Release 2026.1.0 Upgrade date: Thursday 26 March 2026 Start time: 2:00 AM (EDT) End time: 6:00 AM (EDT) Impact: Users will not be able to log into the application during the maintenance window. Clock and Clocks+ web clocks cannot be registered on a new browser window during the maintenance window. Previously registered web clocks will continue to accept punches. Punches will be submitted for processing after the maintenance window. All background jobs will be temporarily paused. Reports will not be available during the maintenance window. Web Services (API, OData) will not be available during the maintenance window. The SFTP servers will still be available during the maintenance window. Hardware clocks will continue to accept punches as normal. Dayforce will make every effort to minimize the length of time that the service is unavailable.
Posted Mar 24, 2026 - 09:41 EDT
This scheduled maintenance affected: Ceridian Dayforce HCM.